AdrianChm

Forum Replies Created

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • in reply to: RSS Feed problem & Turning off comments #300
    AdrianChm
    Participant

    Sadly, shortcodes still appear in the feed. Published a new post, and the shortcodes are inside the post. See: http://feeds.feedburner.com/TheAstronauts – I used media and pullquote, and both are visible.

    in reply to: RSS Feed problem & Turning off comments #285
    AdrianChm
    Participant

    Thanks, will check out the RSS-fix. As I said, using HTML editor and thus using [p] and [br/] (sorry, the only way for the comment to accept p and br ;) ) fixed all formatting problems caused earlier by the WYSIWYG editor and its use of & n b s p ;. But it’s nice to be able to use shortcodes again!

    As for the comments for now I’ve just edited ‘no comments’ out of any occurrence in any php, and removed:
    [?php comments_template( ”, true ); ?]
    from single.php. That did the trick :)

    • This reply was modified 10 years, 1 month ago by AdrianChm.
    • This reply was modified 10 years, 1 month ago by AdrianChm.
    • This reply was modified 10 years, 1 month ago by AdrianChm.
    • This reply was modified 10 years, 1 month ago by AdrianChm.
    • This reply was modified 10 years, 1 month ago by AdrianChm.
    • This reply was modified 10 years, 1 month ago by AdrianChm.
    in reply to: RSS Feed problem & Turning off comments #269
    AdrianChm
    Participant

    A little update. The RSS problem goes away (posts are properly formatted) if:

    a) One stops using WordPress’ WYSIWYG editor for posts and write directly in HTML editor (which I am hearing is a thing to do no matter what).

    b) One does not use (the current version) Fuji’s shortcodes. Which is not a big deal, there’s a lot of ways to add captions to images, etc.

    Just wanted to let any visitor know there is a solution if they need one :)

    in reply to: Twitter widget not working #263
    AdrianChm
    Participant

    There were so many… :) The one that I am using atm is this http://wordpress.org/extend/plugins/xhanch-my-twitter/

    It’s probably a bit too advanced for its own good and does have a few problems (compare how it renders on http://www.theastronauts.com in Firefox versus Chrome), but it’s quite decent example of possible functionality nonetheless.

    in reply to: Twitter widget not working #258
    AdrianChm
    Participant

    Holy …!… Amazing.

    Andrew, “while you’re at it”… :) Here is a couple of suggestions. Now, I don’t want to be THAT guy (who gets his request resolved, so he begins spamming the creator with tons of new ones :) ), it’s just that I have tested about ten different Twitter widgets for WordPress and I think I now which extra options can be very useful for users. I think it’s very simple stuff, but do feel free to ignore it if you don’t think it’s worth pursuing!

    1. Options to not include retweets (so tweets beginning with “RT” afaiu) and replies (tweets beginning with @). The reason is that retweets often are not directly connected to the company/blogger, it’s just something we forwarded to others. Replies, on the other hand, are simply not fun to read because visitors to the blog/site don’t know the context and the conversation (that why’s actually you cannot see replies from someone you follow on Twitter unless you follow that other person involved in the conversation too).

    Also, BTW, retweets of long tweets right now seem truncated: they appear okay in Twitter, but not in the widget. For example, when I read Twitter in the browser, I can see that I have retweeted this “properly”:

    @Capy_Nathan: Can’t believe how much folks focus on duration. Short downloadable games should be applauded for their focus, not called out for ‘lacking’.

    …but Fuji’s twitter widget displays only:

    RT @Capy_Nathan: Can’t believe how much folks focus on duration. Short downloadable games should be applauded for their focus, not calle … 1 day ago

    2. Option (or have it by default) to color hashtags (same color as the tweet’s date, for example, so it’s all in harmony).

    3. Option to insert a character before the tweet date, so it doesn’t gel together with the rest of the tweet, e.g. now we have “http://t.co/qN33vKNn 3 hours ago” while it could be “http://t.co/qN33vKNn | 3 hours ago” or “http://t.co/qN33vKNn • 3 hours ago”. Or actually ANY solution that visually separates the date from the tweet (possibly including the option to not display the date at all).

    4. Option (or by default) to “decipher” t.co links. Tweets look like this in the widget:

    Two great adventures in the Fall Bundle: To the Moon, and Blackwell Deception. Get it if you like good stories. http://t.co/qN33vKNn 3 hours ago

    …while it looks like this when you read Twitter in the browser/native app:

    Two great adventures in the Fall Bundle: To the Moon, and Blackwell Deception. Get it if you like good stories. http://www.indieroyale.com

    To be clear, only the first suggestion is something I truly care about (especially the @ mentions part) and would finally allow me to drop the external widget and use Fuji’s native one. The rest is just low priority suggestions (if suggestions can have priority :) )

    in reply to: Twitter widget not working #255
    AdrianChm
    Participant

    It seems like the fix does help with the error line problem, nice!

    in reply to: Twitter widget not working #252
    AdrianChm
    Participant

    Exactly! Worth noting is that the error message was displayed on the website despite the fact that the built-in widget was removed from the sidebar! In other words, even the inactive widget is causing WP to display an error message (I actually cannot confirm whether the active widget does the same thing or not).

    Additionally, if I add then remove, then add again the built-in widget (the new version), the whole Options section of it breaks apart (error message everywhere).

    in reply to: Twitter widget not working #250
    AdrianChm
    Participant

    Some ekstra info. I have installed the newest version of the widget and it seemed to work great. However, since I need two of these (see my post above) and the Fuji one for some reason can only be used once, I have deactivated the widget and kept the one I have found elsewhere. What that caused was this (at the bottom of the page):

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, first array member is not a valid class name or object in /home/content/79/9731479/html/wordpress/wp-includes/plugin.php on line 403

    (Well, at the time I had no idea what caused this line, but as soon as I put WordPress into debug mode I was able to locate the culprit quickly :).

    Replacing the new widget with the old version seems to have fixed the problem (the warning line is gone).

    in reply to: Twitter widget not working #249
    AdrianChm
    Participant

    I’m sure it works (thank you!), and will use the new file as soon as possible. Meanwhile, additional thing about the widget: I have noticed that you can use only one widget at the time, i.e. there’s no way to put two Twitter widgets into the sidebar. If that is a big deal to fix, no worries, I will stick to the external plugin (you can see how it works on our site: http://www.theastronauts.com) – although if that’s an easy fix then of course I’d like to use the prettiness that is the native widget :)

    in reply to: Default font size #248
    AdrianChm
    Participant

    Thank you, that worked like a charm. And yes, it’d be great to have it as on option, e.g. in the Typography tab :)

Viewing 10 posts - 1 through 10 (of 10 total)