RSS Feed problem & Turning off comments

Front page Support Forums Fuji Theme Support RSS Feed problem & Turning off comments

This topic contains 6 replies, has 2 voices, and was last updated by  satori 5 years, 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #253

    AdrianChm
    Participant

    Instead of multiplying topic, let me ask about two things in one and be done with it ;) I’ve been using the theme extensively in the last week, and apart from the Twitter widget and the default font size things I talked about in other threads, I’ve noticed only two more problems:

    1) RSS feed output is broken in two ways:

    a) all shortcodes are visible in the feed like they are a regular text part of the post, e.g. what looks like this in the post:

    Let me tell you, we are not making a shooter. (with the last few word highlighted using HIGHLIGHT shortcode)

    …can look like this in Google Reader:

    Let me tell you, [highlight bg=”#DDFF99″ color=”#000000″]we are not making a shooter[/highlight].

    (oddly enough shortcodes are stripped off properly in Instapaper, it’s just RSS that misbehaves)

    b) all text in the RSS is mashed together. For example a post that’s:

    This is a paragraph one.

    This is a paragraph two.

    This is a paragraph three.

    …in Google Reader will look this way:

    This is a paragraph one. This is a paragraph two. This is a paragraph three.

    Basically, all words in the post become a wall of text :) I looked in the html of the posts, and it seems like whatever is in is displayed properly in RSS, but if the paragraphs is separated with a regular press of the Enter key in the WordPress post (don’t laugh, I am not a coder, so I don’t know how to describe it better :) then this is ignored in RSS and all paragraphs become “glued” together in the feed. However, everything is working properly if I switch the theme to any of the WordPress’ default ones.

    The other problem is a small thing and I can fix it manually by editing a few of the theme’s php files, so feel free to ignore it. But if in the future there’s an easy way to achieve what I need, that’d be great. Anyway, there’s no simple way to disable comments info. When the comments are disabled in WordPress, the theme still keeps on displaying messages like “Comments are closed” (end of a post) or “0 comments” (on the main blog page under each post). I think it’d much be nicer if simply nothing was displayed when a blogger/company decides to not offer the comments option.

    Thanks for listening! :)

    #269

    AdrianChm
    Participant

    A little update. The RSS problem goes away (posts are properly formatted) if:

    a) One stops using WordPress’ WYSIWYG editor for posts and write directly in HTML editor (which I am hearing is a thing to do no matter what).

    b) One does not use (the current version) Fuji’s shortcodes. Which is not a big deal, there’s a lot of ways to add captions to images, etc.

    Just wanted to let any visitor know there is a solution if they need one :)

    #284

    satori
    Member

    Dear Adrian,

    I sincerely apologize for such a delay in my response, I somehow did not see the notification of this forum thread being created.

    The RSS feed:
    – please try replacing the functions.php file with the updated one, this should enable shortcode processing in RSS feeds
    – I’m still looking into the formatting issue, will try to find a fix

    The comments:
    as far as I know, the “comments are closed” message is being displayed even by the default WordPress themes, at least I can see the same code in the template files. Since it is not an urgent issue as far as I understand, I will include an option to disable all comments info in the next Fuji theme update.

    Thank you so much for all the feedback, this really helps polishing the theme!

    Best,
    Andrew | Satori

    #285

    AdrianChm
    Participant

    Thanks, will check out the RSS-fix. As I said, using HTML editor and thus using [p] and [br/] (sorry, the only way for the comment to accept p and br ;) ) fixed all formatting problems caused earlier by the WYSIWYG editor and its use of & n b s p ;. But it’s nice to be able to use shortcodes again!

    As for the comments for now I’ve just edited ‘no comments’ out of any occurrence in any php, and removed:
    [?php comments_template( ”, true ); ?]
    from single.php. That did the trick :)

    • This reply was modified 5 years, 1 month ago by  AdrianChm.
    • This reply was modified 5 years, 1 month ago by  AdrianChm.
    • This reply was modified 5 years, 1 month ago by  AdrianChm.
    • This reply was modified 5 years, 1 month ago by  AdrianChm.
    • This reply was modified 5 years, 1 month ago by  AdrianChm.
    • This reply was modified 5 years, 1 month ago by  AdrianChm.
    #292

    satori
    Member

    Good, let me know if the shortcodes fix works for you ;)

    Best,
    Andrew | Satori

    #300

    AdrianChm
    Participant

    Sadly, shortcodes still appear in the feed. Published a new post, and the shortcodes are inside the post. See: http://feeds.feedburner.com/TheAstronauts – I used media and pullquote, and both are visible.

    #304

    satori
    Member

    Shoot.. I’ll try another fix, yet later this week, if you don’t mind.

    Best,
    Andrew | Satori

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.