Background Slider / Image Source of Images Not Working

New Front EN Support Forums Tokyo Theme Support Background Slider / Image Source of Images Not Working

Viewing 10 posts - 11 through 20 (of 21 total)
  • Author
    Posts
  • #3022
    Sylvio
    Participant

    Hello
    I ve got such the same issue… I setting up a new website today and try to personalize the background slider to a specific page. The fact is it’s looking like the “background slider/image source of images” setting in the editor is just not saved and remains on “None”. Then it’s always the background global option that is used. Maybe a bug with WordPress 3.9 ?
    In personalized fields there is no field for this setting. The Custom Header setting generate a “fuji_header” field so I guess there will be a field I can set for that to workaround, isn’t it ? What I want is to set another NextGen Gallery to use.

    Thanks for help
    Cheers

    #3034
    satori
    Keymaster

    Hey Sylvio,

    I’ve investigated the issue and it seems that the cause of the problem is indeed the fact that the “Background Image/ Source of Slides” metabox does not save its settings properly. Please download this fix I’ve prepared, unzip it, and upload the resulting file into the following folder of your WP installation: /wp-content/themes/Tokyo/includes/supersized/includes/, replacing the existing file. After that please refresh the website and try altering the metabox settings once more. Let me know if this works!

    Sincerely,
    Andrii / Satori Studio

    #3040
    Sylvio
    Participant

    Thank you very much. It’s working well with this patch.
    A last question… I didn’t get how (or maybe there is also a bug about it) to set up the google map header in the contact page.
    Is it also possible to set it as a background ?
    What I did : in the page I set “custom header” to Google Map and in the Theme options / Header elements tab I set the URL of Google Map (new version).

    Thanks again for help.

    #3044
    satori
    Keymaster

    Hey Sylvio,

    glad the fix worked! I’ll add it to the next version update of Tokyo.
    The map issue is not a bug per se, yet originates from the fact that Google has changed its Maps API, including the URL structure. Please try this: go to the Google Maps website, select your desired location view, press the little cog icon in bottom right corner, select “Share and embed map”; in the pop-up window, go to the “Embed map” tab, copy the entire URL and paste it somewhere into a simple text editor (e.g. Notepad) to see the entire URL string. From the string, copy out the part between quotation marks that starts with “https”, e.g. from

    
    

    copy out

    https ://www.google.com/maps/embed?pb=!1m14!1m12!1m3!1d1370560.827953086!2d16.115803796636907!3d47.86135276346923!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!5e0!3m2!1sen!2s!4v1398076715603
    

    Paste that part into the “Header: Google map” field in the “Header Elements” tab of the Theme Options panel.

    Please let me know if this works!

    Best,
    Andrii / Satori Studio

    #3050
    Sylvio
    Participant

    Hello
    Perfect ! Thanks for the embed trick.
    Cheers !

    #3114
    noisesev
    Participant

    Hello again Andrii,

    I’m having some different issues with the background slider. Generally I am still confused whether the ‘image slider’ category has any influence on settings in the background settings (or NextGEN) if one has chosen the background slider as the default content of the custom header (custom header is activated) via theme options. Anyhow, I thought you might be able to help: Despite selecting a slideshow pause on hover and a background URL they don’t work on the actual website. Funnily enough, I am getting a feedback for other settings such as transition time and captions though.

    Cheers,

    Christopher

    #3137
    satori
    Keymaster

    Hey Christopher,

    I’ve investigated the issue and it seems that the settings work fine, it’s the z-indexes (i.e. layer sequence) of the background slider that need to be changed; I’ve prepared a fix – please unzip this archive and upload the resulting file into the theme folder, overwriting the existing file. Alternatively, you can simply add this piece to the theme’s CSS:

    body {
    position: relative;
    z-index: -2;
    }
    #supersized {
    z-index: -1 !important;
    }
    

    Please let me know if this works!

    Sincerely,
    Andrii / Satori Studio

    #3167
    noisesev
    Participant

    Hi Andrii,

    I’ve add the code but it doesn’t seem to make any difference. Which issue was this supposed to resolve?

    Best,

    Chris

    #3175
    satori
    Keymaster

    Hey Chris,

    the above snipped was meant to tackle both issues :) again, since it does work on my testing environment, I’m afraid I’ll have to wait until I see the live code to be able to tell you what the problem is; please note, however, that the “pause” and the “link” settings on the background slider refer to the mouse being above the slider itself, i.e. where the background is “exposed”, not covered by other elements such as the semi-transparent content area or the header.

    Sincerely,
    Andrii / Satori Studio

    #3181
    noisesev
    Participant

    HI Andrii,

    I’m aware of the latter. I’ll then just have to post a live version in the next couple of days! Just to make sure until then: the image slider tab in the theme options has no influence on the background slider, right?

    Cheers,

    Chris

Viewing 10 posts - 11 through 20 (of 21 total)
  • You must be logged in to reply to this topic.