Text Not Displaying Without Resize in Ikebana Theme

Front page Support Forums Ikebana Theme Support Text Not Displaying Without Resize in Ikebana Theme

This topic contains 7 replies, has 2 voices, and was last updated by  satori 3 years, 6 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2774

    Treed0803
    Participant

    Hello,

    http://www.trentreed.net/

    I had some Custom CSS that changes how my website displays, I removed the custom CSS because I thought it was causing this issue, but it did not fix anything. Basically, on Chrome browsers (phone and desktop) whenever you visit my website in a new tab for the first time, the text style is NOT visible. So all my text is just simply invisible. If I “inspect element” on it, the text appears, and if I resize the browser, it ALSO appears. But I don’t want my visitors to have to do either of these things to view my site.

    I’m currently attending a conference where I really would like my website to be available, and I don’t know what’s going on here. I don’t believe this is a theme issue per say, but I don’t know how I would even begin to debug this, as I’ve never run into or heard of this issue before. Any help would be greatly appreciated. Or any tips as to why this issue may be occurring would be wonderful.

    Thank you,
    Trent Reed

    #2781

    satori
    Member

    Hey Trent,

    this hasn’t been reported previously, and I cannot seem to be able to replicate this issue on my machine (see screenshot) so we’ll initially need to debug it together :)

    As the first step, please provide the following information:
    1). Are you using Chrome on an Apple product?
    2). Does the website display text normally in other browsers (e.g. Firefox, IE, Opera) or the problem persists there as well?
    3). Do you have any extensions installed in Chrome? (“Settings -> Extensions”)
    4). Please try switching to the default WP theme (e.g. Twenty-Fourteen) and check if the bug persists.

    Looking forward to hearing from you!

    Best,
    Andrii / Satori Studio

    #2788

    Treed0803
    Participant

    1). No, I was able to replicate it using Chrome on Android, Windows, and Chrome OS.
    2). I don’t have a computer that can run Opera, but on Linux, Windows, and Chrome OS – the Chrome browser does not display text unless I resize the screen or visit another page in my website. I have a friend with a Windows OS, he was able to reproduce in Chrome, but IE works fine.
    3). No, I was using a fresh install of Chromium in Linux, and on Chrome OS, I would run incognito mode in order to reproduce without extensions.
    4). It displays text properly when the theme is the default Twenty-Fourteen theme.

    Thank you for helping me! :)

    #2796

    satori
    Member

    Hey Trent,

    the issue is definitely connected with the theme then, yet since all other users haven’t had this problem, the second piece of the puzzle might be the server: could you please try adding these two lines at the very bottom of the “wp-config.php” file which is found in the root of your WordPress installation:

    ini_set('pcre.backtrack_limit', '1000000');
    ini_set('pcre.recursion_limit', '1000000');
    

    then hard-refresh the page and let me know what happens; in order to hard-refresh the page in Chrome, press F12 (or right-click mouse and “Inspect element”) to open the console, then press and hold the top left refresh button next to the browser’s address bar – you should be able to see a drop-down list of refresh options; choose the last one).

    Sincerely,
    Andrii / Satori Studio

    #2818

    Treed0803
    Participant

    Hello,

    I tried the above, it doesn’t seem to help on mobile. I researched some, and found the following bit of information that may be relevant:
    http://stackoverflow.com/questions/21948022/font-face-text-is-invisible-in-chrome-on-refresh-but-not-always
    Seems like it might be a bug in certain versions of chrome? The Stackoverflow answer did not seem to work in all chrome installs though. The major issue is it now works for me, but still does not work for mobile or other random people.

    Any other thoughts that might help? :/

    #2821

    satori
    Member

    Hey Trent,

    I’ve prepared an updated theme file based on the recommendations from the link you’ve provided – please download this archive, unzip it, and upload the contained file into the theme folder (/wp-content/themes/Ikebana) replacing the existing file. Let me know if it works!

    Best,
    Andrii / Satori Studio

    #2823

    Treed0803
    Participant

    Hello,

    When I replace header-functions.php, my page does not display, it shows up as a grey page.
    I would leave it up for you to see, but unfortunately at this time I cannot leave my page not working.

    Thank you,
    Trent Reed

    #2829

    satori
    Member

    Hey Trent,

    if you are able to provide me with the access to the WP admin (you can send the credentials to support@satoristudio.net), I can insert the code myself.

    Sincerely,
    Andrii / Satori Studio

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.