Featured Image not showing up in portfolio page

Front page Support Forums Kanso Theme Support Featured Image not showing up in portfolio page

Tagged: 

This topic contains 8 replies, has 2 voices, and was last updated by  satori 3 years, 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2127

    ericaheinz
    Participant

    Hi, we’re adding featured images in each portfolio project, cropped to the right dimensions, but they’re not being used. The portfolio section is just showing the whole image as a background.

    The featured image shows up in the admin: http://cl.ly/image/413x1P0u1d2x
    But not on the site: http://cl.ly/image/3u1X3H1f2u0E

    Here’s our site:
    http://celebratememory.com/masresha/

    Any suggestions? Thanks!

    #2134

    satori
    Member

    Hey Erica,

    first of all, thank you for the purchase!

    The image shown in your first screenshot does appear on the website, please see the highlighted portfolio item on my screenshot. Portfolio projects display images as backgrounds in Kanso in order to enhance theme flexibility and allow for compatibility with high-resolution displays. The background images are positioned in the middle of the portfolio items to fit in with maximum efficiency by using the CSS “background-size: cover” method. In this case the original image is quite elongated vertically (source), which makes it cropped in the portfolio grid. Please try making the thumbnail source image more “square”, i.e. closer to the dimensions of the portfolio boxes.

    P.S. I can see that there’s a small CSS bug in the theme by looking at the positioning of the portfolio grid on your website – I recommend downloading this fix and updating the theme files (simply upload the contained file into the theme root folder /wp-content/themes/Kanso/).

    Sincerely,
    Andrii / Satori Studio

    #2138

    ericaheinz
    Participant

    Thanks for getting back to me so quickly!

    Right, the image itself is showing up, but the thumbnail (which we’ve cropped) does not. The image you highlighted should be this one: http://celebratememory.com/masresha/wp-content/uploads/2013/12/thumb-300×222.jpg

    The thumbnail is showing up as the “featured image” in the project, just not on the home page. Does the “image” format not use the thumbnail?

    I’ve uploaded the theme fix but it didn’t change anything.

    Thanks,
    Erica

    #2143

    satori
    Member

    Hey Erica,

    the last file I sent you was not intended to alter the image, it was to fix a small bug that I found at the same time; sorry for mis-communication :)

    As to the issue, please try removing and re-uploading the thumbnail for the project in question – the mechanism that displays the project box background image takes the latest of all images attached to a particular project, including both the images in the content and the attachment (in WordPress, all of them are considered attachments). Let me know if this helps!

    Sincerely,
    Andrii / Satori Studio

    #2146

    ericaheinz
    Participant

    Thanks Andrii. I removed and reuploaded the thumbnail, but nothing has changed.

    The thumbnails for videos work, just not the thumbnails for image posts.

    #2160

    satori
    Member

    Hey Erica,

    I agree that the algorithm that sourced the images for portfolio items was unnecessarily complicated; thank you for bringing this up! I’ve completely re-thought it and here’s what I came up with. Please upload the contained file into the theme folder and let me know if it does what you needed (which is, showing the thumbnail as the portfolio item background and the content image as the on-click overlay).

    Sincerely,
    Andrii / Satori Studio

    #2167

    ericaheinz
    Participant

    Thanks so much Andrii. We’re trying to launch this today so the fixes are really appreciated.

    I uploaded the new content-image file, but it doesn’t seem to have changed anything? I deleted and re-uploaded the thumbnail but no luck.

    http://celebratememory.com/masresha/

    #2168

    ericaheinz
    Participant

    Ah, nevermind! I didn’t realize that setting the site up as a multisite meant we had the theme in each subdirectory. I replaced the file in the subfolder, and it’s all working now. Thanks so much!

    #2176

    satori
    Member

    Hey Erica,

    Glad it works! I will include the new code into the theme update to version 1.2 that I’m submitting right now ;)

    Best,
    Andrii / Satori Studio

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.