Deprecated: Function get_currentuserinfo is deprecated since version 4.5.0! Use wp_get_current_user() instead. in /var/www/html/wp-includes/functions.php on line 5383

Top Menu can become uncooperative

New Front EN Support Forums Pre-Order Questions Top Menu can become uncooperative

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #192

    I was able to bug out the top menu by click the ‘leave this closed | leave this open’ links. If you close it above 960px wide and then resize the browser just between widescreen (960?) and slightly below that (950ish?), then you can get a 2nd version of the top menu with a tab. Problem is if you minimize the top menu in this state, and then go back above 960px, the top menu will be minimized but with no tab to toggle it open, effectively disabling the menu. Conversely the other problem would be that it could remain open, with no tab, and when you shrink the browser youll have this un-responsive top menu and also the main-nav dropdown… This ‘middle’ state that is only about 20px wide should be removed.

    I think this is a great theme but this toggling functionality with the top menu isn’t great and it’s an inconvenience. I’d rather see the menu up all the time at full size and maybe at ipad size. Then the dropdown would be effective at smaller sizes.


    Dear Isurus,

    thank you for informing about the bug! I’ll try to fix it for the next version release (1.3) which is due in several weeks. Note that in general it should not be a big problem though since the people who use smaller screens (e.g. browsing from a tablet or a mobile phone) open their browsers already in that mode, i.e. they do not resize the browser window too often (if you re-produce the bug and then reload the page, it works normally); the same can be said about the users with wide screens, although I do agree that some may want to change the width of the window if e.g. they have a very wide screen and they want to be able to see several browser windows in parallel.

    Moreover, there is an option in the Theme Options panel to disable the sliding effect, i.e. to hide the “Menu” tab as well as the toggle links, and to always show the top menu to the user :)

    Once again, I really appreciate the information! If you have other comments or questions, do not hesitate to contact me!

    Andrew | Satori

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.