Set the theme to 100% width

Front page Support Forums Kanso Theme Support Set the theme to 100% width

Tagged: ,

This topic contains 5 replies, has 2 voices, and was last updated by  satori 3 years, 10 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2354

    oren
    Participant

    Hi,

    Great theme!

    I’d like to set the theme to 100% width (in general I’m trying to create website similar to this one).

    My homepage is the portfolio template (here is a temporary link to my website), and I’ve noticed there’s some kind of dynamic max-width rule to the main container – BUT COULD NOT FIND IT!

    Please help…

    Thanks!

    #2359

    satori
    Member

    Hey Oren,

    first of all, thank you for the purchase!

    The “max-width” declaration you’re after is on line 133 of the “responsive.css” file in the theme’s root folder ;) I’ve put the CSS that governs the fluid layout into a separate file in this case.

    If you wish to make the website stretch the entire width of the screen, you can add the following CSS into the “Style: Add Custom CSS” tab of the Theme Options panel (or directly change the “responsive.css” line that I mentioned above):


    body .container {
    max-width: 100%;
    margin: 0 20px;
    }

    Sincerely,
    Andrii / Satori Studio

    #2363

    oren
    Participant

    Hi,
    Thanks for the Answer.
    I’ve tried your solution and it’s not fully working, and I have a guess why:
    It seems that the theme is generating custom CSS code (look in line 605 in the source of my homepage). It’s not only overwriting my CSS files, it also has the !important rule, so I can’t fight it…

    I assume it has something to the portfolio/isotope system? because it seems like it calculate the box-size + margin, and set max-width for it.

    If you can point me again to the necessary changes, it will be much appreciated.

    Thanks,

    Oren

    #2366

    satori
    Member

    Hey Oren,

    the CSS code you’ve mentioned is generated in the “header-functions.php” file; please remove the code on lines 762-810 of that file to disable this CSS.

    Sincerely,
    Andrii / Satori Studio

    #2370

    oren
    Participant

    Hi,
    So it worked,
    but i found that It is also necessary to delete the lines 78-79 in custom-styles.php

    Thanks again,
    Oren

    #2376

    satori
    Member

    Glad to hear! Should you face issues or have other questions about the theme, do not hesitate to contact me.

    Sincerely,
    Andrii / Satori Studio

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.