Deprecated: Function get_currentuserinfo is deprecated since version 4.5.0! Use wp_get_current_user() instead. in /var/www/html/wp-includes/functions.php on line 5383



Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #7059

    I have created a child theme of Ikebana and would now like to translate it. What I have done so far, I opend the Ikebana/languages/localize.po file of Ikebana with PoEdit, translated parts of it and put the translation (localize_DE.po, to the folder Ikebana/languages. Is this the right place? Or should I rather add these files to Ikebana-child/languages?
    Then I have set define(‘WPLANG’, ‘de_DE’); in wp-config.php. Unfortunately my translations are not applied by WP. What am I doing wrong? Thanks a lot for your help!


    Hey Olollo,

    there are two things that need to be done:
    1). in the 4+ versions of WordPress, the “WPLANG” constant has been deprecated; instead, you can use a much more user-friendly “Site Language” setting in the “Settings -> General” admin menu.
    2). the localized .po and .mo files should be named according to ISO standards in WordPress – i.e. de_DE for German. You can find more information on localizing WP here.

    You can put the language files into the parent theme’s “languages” directory in this case, but if you wish to translate only the child theme specifically, you can follow the instructions here, replacing the “total” textdomain with ‘satori’.

    Andrii / Satori Studio

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.