Issues with home page

Front page Support Forums Tokyo Theme Support Issues with home page

This topic contains 12 replies, has 2 voices, and was last updated by  satori 4 years, 8 months ago.

Viewing 10 posts - 1 through 10 (of 13 total)
  • Author
    Posts
  • #1103

    strillogy
    Participant

    I’ve been trying to get the homepage to look like your sample, but I can’t seem to get the background slider to work.

    On your demo the background slider acts like a full slider with left and right navigation and titles/subtitles. It seems I only have options to load from a DIR, NextGen or a gallery from a post. This seems a bit hard to follow. All I’d like to do is set up 4-5 slides with text in something as simple as a custom post type and then activate it, but it seems there are way too many other options that don’t do what I need them to.

    All I get is a little sliver of the image and the rest is covered the the semi-transparent black backgorund.

    #1104

    strillogy
    Participant

    I’ve got a another list of other small bugs I’m finding..but one that is driving me nuts is on the menu colors.

    when I try to select a new color for “Main menu submenu hover background color” it changes the color for “Main menu hover background color” instead of the submenu hover bg….and when I set “Main menu hover background color” to something like RED and then try to set the submenu background to something different it stays purple no matter what I change.

    #1107

    satori
    Member

    Dear Strillogy,

    first of all, thank you for the purchase!

    Regarding the background slider: in “Appearance -> Background Slider”, the “Slides Source” tab, you can choose the default directory from where to source the slides (“Default slides directory” option). You can add the captions to the images e.g. by going to “Media -> Library” menu, clicking “edit” on the uploaded image, and filling in the “caption” field. In case this does not solve the problem, please send me your website’s URL and login details to support@satoristudio.net so that I could provide a more detailed response to this issue.

    The menu colours issue is indeed a small bug, my apologies for that. Please download this fix from my repository, unzip it, and upload into the following folder: wp-content/themes/Tokyo/, replacing the existing file. It corrects the “Main menu hover background color” option; I’ve double checked and the “Main menu submenu hover background color” option already functions as intended.

    Should you have more questions, do not hesitate to contact me, I’ll be glad to help out!

    Sincerely,
    Andrew | Satori Studio

    #1109

    strillogy
    Participant

    Thank you for the response. The background slider still seems a bit hard to manage. I can only choose a folder I upload things via FTP which means control of the title/caption is harder. If I choose a folder from my media library it loads everything in that folder. It really should just be a simple post type, because otherwise I get all kinds of unwanted images inside it or I don’t have the ability to control the captions/titles.

    I ended up just using NextGen Gallery and it still doesn’t really work…nothing shows up for the slider navigation or the title/subtitles. I checked all the options and still can’t see what I’m missing.

    I sent you an email with the details, hopefully it’s an easy fix that I’m overlooking.

    #1110

    strillogy
    Participant

    Sorry one more bug I can’t figure out. Whenever I add a title (like on the homepage) with this:

    ‘h1 style=”width: 100%; text-align: center; margin-top:5px”>title here</h1'

    It doesn't show up.

    #1114

    satori
    Member

    Dear Lowell,

    I’ve checked the website – no bugs there, both issues can be solved by adjusting the Theme Options:

    – the background slider, as well as any other custom header, will only be displayed if the “Display custom header” option is checked in the “Header Elements” tab of the Theme Options panel. You can find more information on the header on page 5 of the Manual. Now the front page is showing the background slider.

    – you’ve checked the “Hide page titles on pages” option in the “Page Elements” tab of the Theme Options panel – this is why the headings are not being displayed on pages ;) You have two choices – either un-check this option or declare the “display: block” style in the H1 tag.

    Regarding the background slider sourcing and captions – the easiest way to achieve a background slider on the front page in your case would probably be to choose the “WP Media Gallery” tab from the “Background Slider/Image Source of Images” options box just below the text area in the page editor mode. Then upload the images you need as simple image attachments (i.e. using the “Add media” button above the text area). The system will then display on that page the background slider composed of the images you’ve uploaded.

    Should you have more questions, do not hesitate to ask!

    Sincerely,
    Andrew | Satori Studio

    #1116

    strillogy
    Participant

    Thanks Andrew.

    I tried enabling the background on these pages:

    Page: right sidebar
    Page: full-width
    Page: left sidebar

    and I get this error and no background on the pages:

    Warning: Invalid argument supplied for foreach() in /home/content/59/9333559/html/v2013/wp-content/themes/Rossi/includes/supersized/includes/WPSupersized.php on line 122

    Warning: Invalid argument supplied for foreach() in /home/content/59/9333559/html/v2013/wp-content/themes/Rossi/includes/supersized/includes/WPSupersized.php on line 122

    Warning: Invalid argument supplied for foreach() in /home/content/59/9333559/html/v2013/wp-content/themes/Rossi/includes/supersized/includes/WPSupersized.php on line 122

    #1117

    satori
    Member

    Dear Lowell,

    I confirm that this is a bug – the function that is matching the current page template with the chosen background settings had a problem in it. I’ve uploaded the fix here, please unpack it and re-upload into wp-content/themes/Tokyo/includes/supersized/includes/, replacing the original files. Please let me know if it works now!

    Sincerely,
    Andrew | Satori Studio

    #1120

    strillogy
    Participant

    Thank you for the fix. That got rid of the error, but now those pages don’t load anything with the background on them. The homepage seems to work, but no other page can use the fullscreen background.

    I’ve tried setting it in the admin panel (right sidebar, left sidebar, full width) and on the specific pages by choosing it from the dropdown.

    #1121

    strillogy
    Participant

    And, there is an issue with the tabs on the homepage even after the fix you sent. All tabs are light gray and don’t show up correctly.

    I’ve tried playing with the settings on the admin panel, but nothing seems to fix the background.

    It would be nice if all of these admin options were predefined with a basic color palette (like most themes do) instead of being completely blank, because it’s hard to know what any of them do. A nice monochromatic base setting option would be nice. Right now everything is completely blank on the admin side of things.

Viewing 10 posts - 1 through 10 (of 13 total)

You must be logged in to reply to this topic.