Can't get Top Menu to display correctly

Front page Support Forums Sensei Theme Support Can't get Top Menu to display correctly

This topic contains 5 replies, has 2 voices, and was last updated by  satori 4 years, 9 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #934

    inoran
    Participant

    Hi,

    I just purchased the Sensei theme yesterday and I really enjoy the look of it so far. It’s really a wonderful theme.

    One problem I’m having is that I am unable to get the Top Menu to display like it does on the demo. I can see the Top Menu text and I can change that and it will update. However, I cannot see the ‘Top Menu Background Color’. I’ve tried changing it different colors but it still doesn’t show up. It just looks like text on the page background.

    Also, if I can get that problem resolved, how do I get the “Use this area to promote somthing” to show up as well?

    Thanks in advance!

    #940

    satori
    Member

    Hey Inoran,

    first of all, thank you for the purchase!

    The problem you are describing has not been reported before, thus I would like to ask you to provide your website’s URL so that I could look at the code.

    Regarding your second question, please go to the Theme Options panel, “Page Elements” tab, and locate the “Promo text in top menu” field – this is where the system sources the promo string for the website ;)

    Sincerely,
    Andrew | Satori

    #945

    inoran
    Participant

    Thanks for the reply Satori.

    My site will be down probably for a few more days as I’m still working on it. Once it’s up, I can give you the link. After thinking about it some more, I may just use the top menu as is though.

    As for the “Pomo text in top menu” field, I’ve searched and searched but I cannot find it in the “Page Elements” Menu or any of the Theme Options panel. Is it possible that it’s missing from my options? Or am I just going crazy? :)

    #947

    satori
    Member

    Dear Inoran,

    Regarding the top menu issue: I think I’ve gotten to the bottom of this. It’s a bug in the code, whereby the top menu only receives the background if the promo text has been switched on. To counter this, please go to “Appearance -> Editor” and add the following line at the bottom of “style.css” (should be opened by default):
    #nav-primary { float: left; }

    My apologies for that, and thanks for pointing it out! I will include the fix in the theme update.

    The “Promo text in top menu” field is located in the “Page Elements” tab of Theme Options, it should be the ninth field and come right after “Author information”. Could you please look again, just in case? If still no success, I will need your admin login and password plus the website’s URL (you can send it to support@satoristudio.net, no disclosure guaranteed).

    Sincerely,
    Andrew | Satori

    #956

    inoran
    Participant

    Hi Andrew/Satori,

    Adding that line to the style.css fixed the color problem with the top menu, thank you!

    I double checked and yes, it seems the “Promo text in top menu” is missing from my Theme Options. It’s not a pressing issue for now but I will contact you by email about this in the near future.

    Two other questions if you don’t mind. :)

    1) Is there a way to change the color of the Post Title for blog entries? Currently it shows up as black and I was wanting to have it appear as red to stand out and users will know to click on it to see the post (I’m using red for all my hyperlinks).

    2) Is there a way to hide the Page Titles for page entries?

    Thanks for your help!

    #957

    satori
    Member

    Dear Inoran,

    to answer your questions:

    1). Please go to the Theme Options panel, “Style: Content, Widgets” tab. There you will find the “Post heading text color” option, which does the trick ;) note, however, that this option will also change the sidebar widget headings. If you do not want that to happen, then we must add one line of code: please go to “Appearance -> Editor” and add this line at the bottom of “style.css” (should be opened by default):
    .blog .post-header h2 { color: #ff0000; }
    and hit “Update File”.

    2). To hide page titles, please add another line of code to the same file:
    .type-page h1 { display: none; }
    note, however, that this will hide headings on all pages; in case you want to be more selective, you can use the following line:
    #post-xx h1 { display: none; }
    where “xx” is the page ID in question. You can locate the page ID by going into the editor mode for that page and looking at the URL in the browser: the numeral after “post=” will indicate the page ID.

    Should you have more questions, do not hesitate to ask!

    Sincerely,
    Andrew | Satori

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.