Bug in portfolio filtering

Front page Support Forums Kanso Theme Support Bug in portfolio filtering

Tagged: ,

This topic contains 6 replies, has 2 voices, and was last updated by  vizzual 3 years, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2278

    vizzual
    Participant

    Hi there! First of all, thanks for the great theme. I really love it!
    Only thing is that I noticed a bug in the filtering of the portfolio in the onepage website.
    When I filter on a categorie, it only applies the filter on the 6 portfolio items that are visible, not on all portfolio items.
    So the results of the filters are incomplete. How to fix this?

    #2283

    satori
    Member

    Hey Vizzual,

    please note that the portfolio filter behaviour is not a bug, rather an intended behaviour: the portfolio grid in Kanso is based on the DeSandro’s Isotope plugin; it is based on jQuery, which means it works with the items already loaded on the particular page. It cannot “find” other projects which haven’t been queried via php because Javascript is a client-side language.

    One solution to this might be increasing the number of portfolio items shown on the portfolio page (use the “Portfolio Items per Page” option on the “Portfolio Page” tab of the Theme Options panel). This will ensure that at least some of the items of each project type get displayed.

    Sincerely,
    Andrii / Satori Studio

    #2285

    vizzual
    Participant

    Hi Andrii,

    Thank you for your quick reply. I understand that it’s a technical issue.

    In that case I would prefer to show a larger amount of items. In the theme settings it’s only possible to change the number per line. But I would like to add another line so it displays nine items in a 3×3 grid.

    Kind regards,
    Juul

    #2289

    satori
    Member

    Hey Juul,

    as I mentioned above, please try changing the “Portfolio Items per Page” setting on the “Portfolio Page” tab of the Theme Options panel, this is separate from the “items per line” setting ;)

    Sincerely,
    Andrii / Satori Studio

    #2298

    vizzual
    Participant

    This does not affect the items shown in the onepage website. Only on the single portfolio page.

    #2311

    satori
    Member

    Hey Juul,

    You’re right :) If you need to control the number of portfolio items in one-page website mode, please use the “Number of portfolio projects per page” option on the “One-Page Website” tab of the Theme Options panel.

    Sincerely,
    Andrii / Satori Studio

    #2324

    vizzual
    Participant

    Found it. Thanks :)

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.