Background Image again

Front page Support Forums Kabuki Theme Support Background Image again

This topic contains 17 replies, has 3 voices, and was last updated by  satori 3 years, 6 months ago.

Viewing 10 posts - 1 through 10 (of 18 total)
  • Author
    Posts
  • #1965

    fry
    Participant

    Hello

    First of all thank you for this very clean template. And for in depth support you are giving. This is not common anymore unfortunately.

    I have well known to you problem with background images. I read all other users’ posts and your replays but nevertheless i can’t figured out why I can’t make it working.

    I’d like to attach different bcg image for each page.

    Here is my setup.

    Theme options: Website bckg – solid color
    Appearnance/Background Image-Slider Options:
    Type of background – single image
    Display:
    Everywhere (even if i ticked it out it comes back automatically after ‘saving’)
    Homepage
    Front page

    Select the page template(s) where the background slider should be used:
    P: bcg slider
    P:full width
    P: contacts

    Slide source:

    Default

    Default slides directory: – supersized-slides (located at wp-content and contains no images but subfolders for particular pages (for example Bcg_home), each s-folder has bcg picture.

    PAGES: Homepage (landing page)
    Page attributes: Page bcg slider
    Bcg slider/Image source: Custom Dir: supersized-slides/Bcg_home

    I’ve noticed that after selecting this Bcg slider/Image source tab and selecting appropriate dir (for example Bcg_home) and ‘update’ and coming back there is no change in Bcg slider/Image source. Under Custom Dir Tab no folder is selected. It looks like change was not applied.

    I also tried WP Media Gallery option by adding image to gallery and attaching to page. It inserts chosen image but not in background.

    I successfully get bcg image if I choose in Appearance/Background Image-Slider/ Slide Source subfolder ( containing a picture. But than I have this image for all pages as a background. I understand it works this way because if custom folder can not be found it goes to ‘Default folder ‘ which in this case is sub folder.

    I’m not sure what I’m doing wrong. I’m working locally so I can’t send you link to back-end now.

    I will be grateful for your help.
    Best regards
    Fry

    #1966

    satori
    Member

    Hey Fry,

    first of all, thank you for the purchase!

    I’ve looked into the issue, and it seems that there was indeed a bug in the theme’s files. I’ve prepared a fix: please download this archive, unzip it, and upload the contained file into the following folder:
    /wp-content/themes/Kabuki/includes/supersized/includes/
    replacing the existing file. Then refresh your website and try changing the meta box settings once more. Please let me know if it works for you!

    Best,
    Andrii / Satori Studio

    #1967

    fry
    Participant

    Thank you very much for help. It works like it should now.
    Just one thing: if I choose under Page Attributes anything but Background slider, footer goes up, it doesn’t stay nicely on the bottom of the page. If text window is long enough then there is no problem but if only there is too little text than footer goes up. How can I control footer position in full-width pages?

    Thanks a lot!
    Fry

    #1968

    satori
    Member

    Hey Fry,

    glad it works, I’ll update the ThemeForest download files as well, thanks for pointing out the bug!

    Regarding your second question: in principle, the footer is not fixed to the bottom of the window, since in that case it will always stick to the window even if there’s more content than window height (you can try any theme on ThemeForest, they’ll also follow the same principle). I wouldn’t also advise to fix the footer on individual pages, since different visitors may have varying screen sizes and to some the footer will overlap the content on smaller screen heights. In any case, it is up to you to decide, here’s how it can be done: please add this CSS code at the bottom of the “style.css” file (opens by default in “Appearance -> Editor” admin menu):
    .page-id-XX #footer { position: fixed; bottom: 0; }
    replace the “XX” with the ID of the page in question. Note that you’ll need to add every individual page separately.

    Sincerely,
    Andrii / Satori Studio

    #1969

    fry
    Participant

    Thank you for quick reply

    I understand what you mean. I will use css additional code for pages where amount of text is minimal.
    Actually I tried this method, I inserted .page-id-XX #footer { position: fixed; bottom: 0; } line in “style.css” (with respective page id numbers “http://localhost/?page_id=327”) but it doesn’t seem to work. It’s on pages with Page Attribute – full width.
    Any chances you could point me what I’m doing wrong?
    Thank you very much, I really appreciate your time spending to help.
    Fry

    #1970

    fry
    Participant

    “″” obviously is not in the actual page address ;-)

    • This reply was modified 4 years ago by  fry.
    #1974

    satori
    Member

    Hey Fry,

    the code I posted above should work on any page template; please check that you’ve inserted the correct page ID: go into the editor mode for the page in question and check the URL in the browser’s address bar: the number you’re after is the one following the “page=” text. Please let me know of the results!

    Sincerely,
    Andrii / Satori Studio

    #1978

    fry
    Participant

    Hello Andrii

    Thank you for replay. I think I did everything correctly regarding page id number. It puzzles me a bit. But never mind, in the worst case I’d like to just drop you my wp back-end access when it will be live. It is minor thing and can be quickly configured.
    Just last thing (I hope), when I insert table form short codes I’d like to align it on the horizontal center of the background body (the one with adjustable transparency).
    I tried to do it simply with align tool from visual editor (html code: ) but it doesn’t work.
    Should it be changed something somewhere in css?
    Of course if you’d like I can put this question in a new post for clarity for forum users.
    Thank you very much.
    F.

    #1979

    fry
    Participant

    Ehm, html attributes changing the look of my citation.
    Once again: (html code: table class=” aligncenter”)

    #1981

    satori
    Member

    Hey Fry,

    this is not a theme issue, nevertheless:
    a table is a special kind of HTML element which has a display=”table” property and therefore requires other positioning approaches. The easiest way to center a table on a page would be to add auto margins to it:
    <table style="margin: 0 auto"></table>

    Sincerely,
    Andrii / Satori Studio

    • This reply was modified 4 years ago by  satori.
    • This reply was modified 2 years, 10 months ago by  satori.
Viewing 10 posts - 1 through 10 (of 18 total)

You must be logged in to reply to this topic.