Theme buggy

This topic contains 4 replies, has 2 voices, and was last updated by  CarolineElisa 2 years, 7 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6703

    Disappointed to find the theme backend very buggy in Chrome and Firefox on a Mac:

    + In the page editor, the visual composer is useless as I can’t scroll down to save my changes http://monosnap.com/image/1JOtIbn5NDTKihDFj1qqySrfz50aeY
    + In the theme settings, when adding images the media library tab is empty http://monosnap.com/image/iIwSRJ4oe9UDb2yoyxw3ZCnlN5HiZr
    + I can’t have more than one Google map on a page http://monosnap.com/image/F3ZGEo3zucZIB6b7yx02lNZaw6Nz5t
    + Email addresses and URLs are not automatically converted to links as they are on many other themes I have used.

    Any plans to fix these issues?

    #6705

    Not sure if I should start a new thread, but here goes:

    In the Theme Options > Styles:Header > Primary menu – submenu background changes the submenu text colour NOT the background:
    http://monosnap.com/image/UJZinaKXMZUZfT8AKrR7Dut1fCfTx6

    #6706

    Me again :)

    The logos and favicon are broken links when I add them in Theme Options > Page Elements, as the urls getting added are in attachment format: …/?attachment_id=935 instead of /wp-content/uploads/logo.png

    #6708

    satori
    Member

    Hey CarolineElisa,

    first of all, thank you for the purchase!

    I will go over the questions in the same order:

    1). “In the page editor, the visual composer is useless as I can’t scroll down to save my changes” – I’ve checked the VC editor in Firefox on OS X Mavericks (via BrowserStack), and it seems to be working fine in theme version 1.3 (screenshot); I’ve sent you the latest version of the theme to the email address you used to register on this forum, please try updating and refreshing the page, if you haven’t tried this already. To update the theme, unzip the archive and copy the entire resulting “Shogun” folder into the “wp-content/themes/” directory on your WordPress instance, overwriting all existing files. If this does not help, I will need to ask you to provide access to the website’s back-end, if it is already available online; you can send your admin login+password to support@satoristudio.net; no disclosure guaranteed.

    2). “In the theme settings, when adding images the media library tab is empty” this is a known issue, which has solved in one of theme updates – could you please check if it persists after you update the theme?

    3). “I can’t have more than one Google map on a page” – this is indeed a bug, my apologies and thank you for reporting! I hand to do with duplicated ID’s for map containers; I’ve improved the code to provide unique IDs – please download this archive, unzip it, and upload the resulting file into the following folder inside your WordPress installation: /wp-content/plugins/js_composer/composer/shortcodes_templates/ , replacing the existing file.

    4). “Email addresses and URLs are not automatically converted to links as they are on many other themes I have used</i>” – this is not a default feature of WordPress, and wasn’t intended as a feature in the theme so far as well. Thank you for the suggestion, I will consider adding it to the next theme update. Meanwhile, you can use the Autolink URI plugin to automatically convert links into clickable markup.

    5). “In the Theme Options “Styles:Header > Primary menu – submenu background” changes the submenu text colour NOT the background” – you’re right, that’s a bug as well! Sorry for that, one extra comma in the code can sometimes screw things up :) I’ve included a fix in the version of Shogun I’ve sent you, so the problem should be solved after an update.

    6). “The logos and favicon are broken links when I add them in Theme Options > Page Elements, as the urls getting added are in attachment format: …/?attachment_id=935 instead of /wp-content/uploads/logo.png” – this can sometimes happen because of the way WordPress galleries work, and the solution is covered on page 4 of the theme manual; for your convenience, I’m including the relevant passage below:
    In case the „Link URL” field displays an attachment URL (ending with „?attachment_id=xx”) press the „File URL” button below the url field so that the link is a direct url of the image file (ends with the filename of the uploaded file). Once you have chosen the item and settings, press „Add to OptionTree”.

    Should you encounter problems with any of the above issues, please let me know, I’ll be glad to provide further assistance!

    Sincerely,
    Andrii / Satori Studio

    #6712

    Thanks so much Andrii!

    Just a couple of things are not quite resolved:

    1. “In the page editor, the visual composer is useless as I can’t scroll down to save my changes” – This is only the case for some of the elements with larger edit boxes. For example Google maps: http://monosnap.com/image/EmA912rzvDeSPdh5J9BRu5knCsSShn

    5. “In the Theme Options “Styles:Header > Primary menu – submenu background” changes the submenu text colour NOT the background” – this setting now applies to both the submenu text colour AND the background. Shouldn’t there be a separate setting for the text colour?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.