Sticky header issue

Front page Support Forums Shogun Theme Support Sticky header issue

Tagged: ,

This topic contains 5 replies, has 2 voices, and was last updated by  satori 3 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3864

    skafte
    Participant

    Hi Andrii,

    Firstly, thanks for Shogun – I really really like it. Well done! It seems that I am becoming a regular customer now both having purchased Ikebana and Shogun… :-)

    Anyway, to the point, I am experiencing an issue with the fixed header functionality; it doesn’t seem to work and I can’t work out why. Here’s the dev site on which I am customising and building the website: http://onlygraphicdesignerscare.com/ – would you mind taking a look and seeing if you can work out why this happens?

    Thanks, I hope you can help.

    Best,

    Jonas

    #3869

    satori
    Member

    Hey Jonas,

    my apologies for the delay in my reply, I was away without Internet access for several days.

    If you want the header of your website to stay fixed on top when the page is scrolled (like in the theme demo), please make sure that the “Deactivate fixed header” checkbox in the “Header Setup” tab of the Theme Options panel is NOT checked. In case it isn’t and the header still does not stick to the top on scroll, please let me know!

    Sincerely,
    Andrii / Satori Studio

    #3871

    skafte
    Participant

    Hi Andrii,

    Thanks for your response and no worries re the wait – I am just pleased that you can help :-) Hope you enjoyed some nice days offline!

    I’ve double checked that the “Deactivate fixed header” checkbox is definitely NOT checked, and the header is still not sticking. I thought that perhaps it could have to do with the rest of my header set up (ie. that it’s center aligned), but then I tried to left align it and it still didn’t stick. Do you think perhaps it could be something else about the set up that prevents it from working?

    Thanks,

    Jonas

    #3877

    satori
    Member

    Hey Jonas,

    I’ve studied the code and found the reason for the bug: the “allow_url_fopen” parameter in your server’s php.ini settings has been disabled, which led to the function that governs the fixed header generating an internal error and terminating. Haven’t taken this possibility into account earlier, thanks for bringing this up! Server-side restrictions should not impede the work of vital theme elements, so after some experimenting I’ve prepared a fix that also works when the “allow_url_fopen” has been turned off – please download this archive, unzip it, and upload the resulting files into the theme folder (/wp-content/themes/Shogun/), replacing the existing files. Let me know if the fix works!

    Sincerely,
    Andrii / Satori Studio

    #3879

    skafte
    Participant

    Merci beaucoup!

    Worked like a charm! – you’re a legend Andrii! :-)

    After adding your fix I decided to also add .fixed-header #logo { display: none !important; } as I would like to have the logo disappearing on scroll (due to tall centered layout). Now I’ll look into making the transition smooth also when the logo is hidden (it’s a bit bumpy at the moment). Anyway, all good! Thanks for your help!

    Cheers,

    Jonas

    #3883

    satori
    Member

    Good! Thanks for bringing this up in the first place!
    Should you have other questions or issues with the theme, do not hesitate to contact me.

    Sincerely,
    Andrii / Satori Studio

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.