Multi-lingual, margins, loading

Front page Support Forums Ikebana Theme Support Multi-lingual, margins, loading

Tagged: ,

This topic contains 11 replies, has 2 voices, and was last updated by  satori 4 years, 1 month ago.

Viewing 10 posts - 1 through 10 (of 12 total)
  • Author
    Posts
  • #1524

    aleplin
    Participant

    To whom it may concern,
    I’ve already installed the ikebana template and I’m very happy with it, however, I have some issues I still can’t figure out:

    1. is it possible to make the site using the ikebana template multi-lingual?
    2. how can I change the margin in between boxes (in the portfolio format)? I’ve already tried using the css in the editor, but I can’t find the class that controls all type of boxes (images, articles, quote)
    3. Is there a way to avoid having boxes align to the left when the site is loading?

    Sincerely,
    Alejandra Perez Lin

    #1532

    satori
    Member

    Hey Alejandra,

    first of all, thank you for the purchase!

    I will answer your questions in the same order:

    1). Ikebana uses the native WordPress localization functions (“_e()” and “__()”) on all strings, so there shouldn’t be any problems using multilingual plugins (e.g. Xili Language or WPML). If, however, you face any difficulties in localizing your website, please do not hesitate to contact me, I will be glad to help.

    2). The setting you’re after is the “Portfolio page items: box margins” field in the “Portfolio Page” tab of the Theme Options panel ;)

    3). Sorry, but this is probably not possible – the margins of the main content area are determined by jQuery scripts, which cannot safely initialize before all DOM elements on the page have been loaded (i.e. until all html on the page is already visible).

    Sincerely,
    Andrew / Satori Studio

    #1541

    aleplin
    Participant

    Thanks for your prompt reply!
    I have just one more question to ask you.
    I’m having some problems with the page title, in pages with a portfolio template. I’ve already selected the option to hide them, (theme options>hide page titles on pages) however, they still keep on showing up on the website. I also tried hiding them through the css using the following rule:

    portfolio-header{display:none; position:absolute;}

    This didn’t work, because even though they were hidden, they still take up space.
    how can I solve this?
    thanks again
    Alejandra

    #1545

    satori
    Member

    Dear Alejandra,

    please clarify – do you want the titles to be hidden on pages with the “Portfolio” template – or on the portfolio projects (i.e. the pages you get to when you click any of the portfolio boxes)? If the former, then the Theme Options setting “Hide page titles on pages” (“Page Elements” tab) should do the trick. In case you meant the latter, the Theme Options setting mentioned above will not affect them, since they are not pages but posts (of type “Project”); in this case you can use the following CSS:
    .single-project .post-header { display: none; }

    Please let me know if I misunderstood the question!

    Sincerely,
    Andrew / Satori Studio

    #1546

    aleplin
    Participant

    Hi Andrew,

    What I wanted to do was to hide the title in the Portfolio template, I’ve already chosen the “hide page titles on pages” option, however, the title still appears randomly once in a while and then disappears. I would like to know how to avoid this weird behaviour.
    I have some other questions I would like to ask you:

    1. can the height of the footer be controlled through the css?
    2. which format should I choose to display a logo in the same way you do in the ikebana page (without any icon con the right hand corner)?
    3. something strange is happening to my menu. If I enter any box in the portfolio (for example one with format article), once I’m inside that page and use the menu, I’m redirected to a 404 (page not found) error. (you can see it here http://fx2.com.uy/site/project/canarias/ )

    Thanks again for your help
    sincerely
    Alejandra

    #1548

    satori
    Member

    Dear Alejandra,

    regarding hiding the title on portfolio page – could you please provide the direct URL of the page in question?

    I will answer the additional questions in the same order:

    1). Yes, you can add this line: #container-footer { height: 400px; } in the “Style: Add Custom CSS” tab of the Theme Options panel, replacing the “400” with any number you like.

    2). I’m using the following settings in the “Page Elements” tab of the Theme Options panel in the demo.

    3). Every icon menu item in the “Icon Menu” tab of the Theme Options panel should have either the “Link URL” of the “Filter” field filled in in order to function properly. Please check if this is the case on your website.

    Sincerely,
    Andrew / Satori Studio

    #1549

    aleplin
    Participant

    Hi,
    this is the url: http://fx2.com.uy/site/
    however, at the moment the title is not showing, though it did an hour ago.

    #1550

    satori
    Member

    Dear Alejandra,

    that’s odd, since the portfolio template file in Ikebana (“page_portfolio.php”) does not even contain a title tag. In case it appears again, please let me know!

    Sincerely,
    Andrew / Satori Studio

    #1551

    aleplin
    Participant

    Andrew,

    I think I can now reproduce both the problem with the title and the one with the menu:

    title:
    1. http://fx2.com.uy/site
    2. select the box with white spheres with this url> http://fx2.com.uy/site/project/tecnologia/
    3. click the 5th icon on the icon menu (empresa)
    4. in this page you will find a hole on the grid where the title should be (it’s still there, just invisible because I included a display:none, in the css for the title)

    broken menu
    1. http://fx2.com.uy/site/project/desarrollo/
    2. click on the 3rd icon on the menu (portfolio)
    3. You’ll then be redirected to this page http://fx2.com.uy/site/tag-portfolio/portfolio (which does not exist and I never created)

    thanks again and sorry for all the trouble
    Alejandra

    #1555

    satori
    Member

    Dear Alejandra,

    regarding the 2×1 portfolio tag tile: you cannot make it go away with CSS, since it has a wrapping div which only has a class and no unique ID. To remove the tile, please download this custom file I’ve made for you, unzip it, and upload into the theme folder (/wp-content/themes/Ikebana), replacing the existing file.

    Concerning the icon menu links: I can now see that the page http://fx2.com.uy/site/tag-portfolio/portfolio/ exists – have you resolved this issue?

    Sincerely,
    Andrew / Satori Studio

Viewing 10 posts - 1 through 10 (of 12 total)

You must be logged in to reply to this topic.