Homepage Slider?

Front page Support Forums Tokyo Theme Support Homepage Slider?

This topic contains 5 replies, has 2 voices, and was last updated by  satori 3 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3724

    vonnagy
    Participant

    Hi,

    First of all this is a very nice theme. I’ve looked through the forum and managed find most of the most of the options. As I haven’t worked wordpress in several years, this might seem a bit basic; and hopefully easy to resolve as well.

    Our website is here: http://whitecloudbrewers.co.nz/, it is currently a work in progress (nevermind the lipsum). On your demo https://satoristudio.net/tokyo/, you have a ‘slider’ which highlights the ‘middle’ of the background image, also which allows the user to scroll through images. There is text on these “Respect your clients And you will succeed”, “We help grow businesses From the ground up”, “A website is your Window into the world”.

    I don’t have demo content (Tokyo_demo_content.xml) installed on the live site, but it is installed on my local site. I would like to have have that bit describe above working on my site, unfortunately I haven’t been able to figure this yet.

    best regards

    #3730

    satori
    Member

    Hey Vonnagy,

    first of all, thank you for the purchase! Glad you’re enjoying the theme.

    Regarding your question: to display the background slider as shown on the front page of the Tokyo demo, please make sure that the following conditions are met:
    – the “Display custom header” option is ticked on the “Header Elements” tab of the Theme Options panel.
    – go to edit mode on the page you wish to show the slider on, and choose “Background Slider” from the drop-down in the “Custom Header” settings box (located below the main content edit area).

    Let me know if the slider still fails to show after the above manipulations!

    Sincerely,
    Andrii / Satori Studio

    #3752

    vonnagy
    Participant

    Hi Andrii,

    Thanks so much for the response. I got it to work, but unfortunately not the captions:

    I used wp-content/supersized-slides as default directory. In Appearance -> Background Image/Slider Options: Slide Caption is ticked with this description:

    >Captions for images from your default or custom directories are extracted from the IPTC caption field of each image.
    >Captions for NextGEN Gallery images are taken from the Description field. If not filled in, the Alt&Title field will be used.
    >Captions for WordPress Media Gallery images are taken from the Caption field. If not filled in, the image title (filename) will >be used.

    I’ve added metadata for the default gallery images; I couldn’t get these captions to appear under default gallery. I’ve installed the NextGen Gallery, but the images never load in the background -just grey background and spinning loading icon.

    Is there a step I am missing to get the captions in background slider?

    #3760

    satori
    Member

    Hey Vonnagy,

    have you tried adding captions to the uploaded images when using the “WP Media Gallery” as the source of images? You can also add captions post-facto by going to the “Media -> Library” admin menu, clicking on the needed image, and filling in the “caption” field – this is exactly how the theme demo front page does it. Please let me know if this still doesn’t work!

    Sincerely,
    Andrii / Satori Studio

    #3763

    vonnagy
    Participant

    Hi Andrii,
    Thanks for this suggestion. I had a look this, but I am a bit puzzled:

    1. I have a installed the plugin “WP Media Gallery” added a gallery with the photos. These all have captions.
    2. On my homepage, for ‘Choose header for this page’ I’ve selected Background Slider
    3. Here is where the problem is: for “Background Slider/Image Source of Images” i select “WP Media Gallery” and update the page it remains on none. It says “Images from the WP Media Gallery attached to this post/page will be used.” I am not sure how to attached the “WP Media Gallery” to the page? Click on “Add Media” for the page doesn’t include my new “WP Media Gallery” images.

    Could you point me in the right direction?

    #3774

    satori
    Member

    Hey Vonnagy,

    I think I know where the source of the issue is: the “WP Media Gallery” tab in the “Background Slider/Image Source of Images” settings box refers to the native WordPress media gallery (i.e. the “Media” admin menu), not to a third-party plugin; this is mentioned on page 8 of the theme manual, yet I will make sure that it is explained in more detail in the next versions. When you choose the “WP Media Gallery” tab, the slider will source images from the image attachments of that particular page, i.e. every image you upload either via the “Add Media” link above the content editor, or as the featured image. Note that for the images to be included in the slider, you do not need to actually insert them into the page (i.e. pressing the “Insert into page” button) – simply uploading them from that page is enough; also, for the images to be displayed in the slider, they need to be attached to the page, i.e. uploaded from that page (that means that if you choose an existing image form the Media Library tab while in the image upload pop-up, it will not appear in the slider for that page).

    Sincerely,
    Andrii / Satori Studio

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.