Column end + Google Maps

Front page Support Forums Kanso Theme Support Column end + Google Maps

This topic contains 6 replies, has 2 voices, and was last updated by  satori 3 years, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #3135

    Tuktop
    Participant

    Hello!
    First of all, I love your template and enjoy using it! Keep up the great work!

    Two things:

    1) In a page, if i add some text after i use columns (i ‘closed’ the last one with last=”1″), this text is not added below the columns and is not using the full width of the page, but it is ‘part’ of the last column. Is this intended?
    I made a workaround by putting the text that should be below the columns in a 5-6 column with last=”1″ so the result is fine.

    2) Is it possible to make the Google Maps embedding non-draggable/zoomable? I think the Google API supports this. This seems to me a very important feature in a one-page template because scrolling through the website gets weird if the cursor reaches a Google Maps embed (it zooms the map instead of scrolling the website); this might be confusing for users.

    Thanks in advance for your reply! Regards

    #3139

    Tuktop
    Participant

    Update, a third question:

    Is it possible to disable the scrolling effect that happens when one clicks a button? E.g.: is it possible to just make it go the desired page instantly?

    #3142

    satori
    Member

    Hey Tuktop,

    foremost, thank you for the purchase and the kind words!

    I will go over the issues in the same order:

    1). I am not sure I understood the situation fully – would you be able to provide a link to a live page so that I could have a look at the actual code? Thanks!

    2). The Google Maps API does allow inserting a map without a mouse-scroll response, yet it is a wholly different approach than the one currently used in the theme (the embed). The non-scrollable maps require a somewhat more complicated setup, which is detailed here. I’m planning to implement it in a future version of Kanso, yet it might take some time; At the moment I’d recommend trying this plugin, which is also based on the Maps API3.

    3). It hasn’t been envisaged in the back-end, yet you can always disable it by removing/commenting out lines 575-584 of the theme’s “header-functions.php” file. If you need help with that, just let me know.

    Sincerely,
    Andrii / Satori Studio

    #3145

    Tuktop
    Participant

    Hello Andrii,

    Thank you for your quick reply! Point 2 and 3 are resolved, i will look into those.
    Point 1: i made an example page within the website i’m currently building; see http://praktijkmariarenders.nl/#page-holder-161
    I hope it’s clear now. Btw: because of the workaround, this isn’t an actual problem for me, but it seems like a good idea to look into it even if it is only to improve the template in general!

    #3155

    satori
    Member

    Hey Tuktop,

    thank you for the demo :)

    I’ve improved the code that generates the column shortcodes in the first place, so that no workarounds are needed – please download this archive, unzip it, and upload the resulting file into the following folder:
    /wp-content/plugins/shortcodes/lib
    replacing the existing file.
    Let me know if it works better now with the fix!

    Sincerely,
    Andrii / Satori Studio

    #3179

    Tuktop
    Participant

    Great! I changed nothing about the content of the page and now both example-sentences correctly show up below the columns.
    I have to remove the example page now because the site will be shown to the client today, so sadly you can’t see the result, but you fixed it! Thanks a lot.

    Your support is awesome by the way; you just got another well-earned 5-star rating on ThemeForest! :)

    Regards,
    Jesse

    #3193

    satori
    Member

    Thank you, Jesse, and glad to hear the fix works!
    Should you have other questions, do not hesitate to contact me.

    Sincerely,
    Andrii / Satori Studio

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.