Childtheme – Portfolio Page not working

Front page Support Forums Ikebana Theme Support Childtheme – Portfolio Page not working

This topic contains 4 replies, has 3 voices, and was last updated by  satori 1 year, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6953

    olollo
    Member

    I have created a child theme based on your Ikebana Theme. When I copy the header.php file to the child-themes main folder, then the portfolio page (I use it as my start page) does not work. All tiles are left-aligned and in a vertical line.
    I guess, that some link to a js file or a css file might be linked to the wrong place. But I didn’t find out anything on my own. What am I missing?

    Thanks a lot for your help!
    Sarah

    #6954

    olollo
    Member

    I think I found what was missing: the header-functions.php file. Is that correct?

    #6956

    satori
    Member

    Hey olollo,

    the child theme’s portfolio grid page should work even when the child theme only has the required “style.css” file – I’ve just double-checked this on the theme demo website. You might want to update to the latest version of Ikebana (3.4 at the moment, is available from the “Downloads” tab of your ThemeForest account) and try once more; alternatively – yes, the “header-functions.php” file is the one containing the script that initializes the portfolio grid, other external script files are referenced in the “functions.php” and should load automatically.

    Let me know if you keep having problems with the child theme!

    Sincerely,
    Andrii / Satori Studio

    #7062

    ad
    Member

    Hello,
    i’ve got the same problem:-(
    i just copy header.php and header-functions.php to my child-theme and the protfolio-page is broken.
    i got the newest version (download tomorrow).
    so is there a trick, a missing file or something else?
    thank you:-)

    greetings
    AD

    #7069

    satori
    Member

    Hey AD,

    could you please provide a link to the website in question? I will be able to provide a more precise recommendation/fix if I see the actual code.
    Thanks!

    Sincerely,
    Andrii / Satori Studio

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.