portfolio page with individual text sidebar

Front page Support Forums Ikebana Theme Support portfolio page with individual text sidebar

This topic contains 8 replies, has 2 voices, and was last updated by  alangreg 10 months, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #7085

    alangreg
    Member

    Hello

    is it possible to have a text sidebar on the portfolio pages (not the masonry style homepage). There is no option on my portfolio pages to select an extra sidebar or in the widgets settings to allocate a text sidebar to that individual page

    #7113

    satori
    Member

    Hey Alangreg,

    first of all, thank you for choosing Ikebana!

    There is a section called “Post layout” in the right-hand side of the editor view for each project, which allows you to control whether or not a particular project has a sidebar; if that one doesn’t show by default, please click on the “Screen Options” tab in the top right corner of the editor view and tick the respective box.

    If you need each project to have unique content in the sidebar, you can use the theme’s built-in custom sidebar functionality; new sidebars can be created in the “Appearance -> Custom Sidebars” admin section, filled with widgets in the “Appearance -> Widgets” section, and assigned to a specific project by using the “Sidebar” settings box in the right-hand side of the editor view for that project.

    Please let me know if you face any difficulties with this one, or in case I misunderstood the question :)

    Sincerely,
    Andrii / Satori Studio

    #7154

    alangreg
    Member

    thanks

    I tried that before but after settting up a new sidebar there is no option to select it in the “Sidebar” settings box – just ths:

    You can assign specific sidebars to this post, just select a sidebar and the default one will be replaced, if it is available on your template.

    There are not replaceable sidebars selected. You can define what sidebar will be able for replacement in the Custom Sidebars config page.

    #7192

    alangreg
    Member

    also – the ‘sticky button’ uncheck is no longer working. I downloaded your fix but don’t understand where I should put what looks like a php file into my website

    #7195

    satori
    Member

    Hey Alangreg,

    I’ll go over the issues in the same order:

    1). Please excuse me, forgot one more thing: try selecting the necessary sidebar areas (in your case – Sidebar) in the “Replaceable Sidebars” section in the top left corner of the Appearance  Custom Sidebars admin section and clicking on “Save changes” underneath.

    2). The unzipped php file should be uploaded into the following folder inside the WordPress directory of your website: /wp-content/themes/Ikebana – via an FTP client or using your hosting provider’s file manager, available on most hosting management admins such as cPanel or Plesk.

    Sincerely,
    Andrii / Satori Studio

    #7197

    alangreg
    Member

    HI

    have had to re-install my wp file on my host. i don’t seem to be able to set the portfolio masonry style page up – it is not giving me the option to select the portfolio template in my page attributes – as your manual says:

    Once you have one or more Project items, you can create the portfolio page which will display all existing Projects in a flexible masonry layout (see the front page of the theme demo for an example) – for that you will need to add a new page (“Pages -> Add New”) and give it a “Portfolio” layout from the “Template” drop-down in the “Page Attributes” settings box on the right hand side of the page edit mode screen. Every project may be displayed in two sizes in the masonry – either standard or large; the size can be chosen individually for each project while in the edit

    #7198

    alangreg
    Member

    Hi

    sorry – ignore last post

    was looking in “portfolio pages”, not “pages”

    however i am uploading my logo and inserting into post tree (3 attemps) but still not showing on website, or even on the “theme options/page elements admin page

    #7199

    satori
    Member

    Hey Alangreg,

    when in the file upload pop-up, please check the “File URL” field after uploading the image: in case it displays an attachment URL (ending with “?attachment_id=xx”) or an empty field, press the “File URL” button below the url field so that the link is a direct address of the image file (ends with the filename of the uploaded file and an image extension, e.g. .jpg or .png). Once you have chosen the item and settings, press “Add to OptionTree”. Do not forget to also click on the green “Save all changes” button in the top/bottom right corner of the Theme Options panel.

    Please let me know in case the above information does not help to solve the issue – we’ll keep looking for a solution!

    Sincerely,
    Andrii / Satori Studio

    #7201

    alangreg
    Member

    yup – thats done it

    thanks

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.